This time, you’ll need to secure your FireFox…

When I heard about FireFox for the first time and how cool it was and how secure it was. I thought that what makes FireFox really secure is the fact that it’s not a widely used browser. I also thought that, if it became a major player in the browsers market, it will soon be discovered to be vulnerable too. Just like Internet Explorer.Today, I read an article that proves my theory.

Quoting:

FireFox


Firefox browsers with a version number below 1.5.0.7 are vulnerable. Please upgrade your Firefox to the latest version. The Mozilla foundation has released a security advisory for this problem. Note that the beta versions of Firefox 2 are also vulnerable!

Note: security advisory means “Service Pack”.

So we’re now running to the same problem in FireFox that we originally faced in Internet Explorer. Please keep in mind that this is just the beginning and that you’ll be reading more articles about such problems in the future.

What I want to say is that FireFox had 2 major advantages:

1. It’s secure…well, now you know it’s not after you read the above article.
2. Its cool… well, you can try Smart Bro to see that it’s not

Browse the web smarter … use Smart Bro.

Tony Sticks,
Mind Vision Software (MVS)

Tags: , , , , ,

Leave a Reply

You must be logged in to post a comment.